Issues with rootfs update


So I was just re-testing this particular feature. Where I would remove an package from my yocto image recipe.
Generate a .mender file and perform a rootfs update to check if the package was removed or not.

Then Add them again in my image recipe and perform a rootfs update to see if they were added back or not.

I have seen this work before. But today after a successful update. I don’t see the changes taking place.
Am I missing something?
the packages get added and removed by removing/adding them in IMAGE_INSTALL_append variable

So I found out that the issue is in removing the ssh service. I tried removing other application like tcpdump and iftop and was successfull. But I was not able to remove ssh.

Depending on the image you used, ssh may be installed by a different mechanism. If you are using the default local.conf provided by poky with their default setup-environment script you probably have the following in your local.conf:

EXTRA_IMAGE_FEATURES ?= "debug-tweaks"

This adds in a number of things including ssh since it’s handy for debugging. The help text in local.conf prior to this setting should clarify a bit.


You are correct. I was a little slow in updating this ticket. I had qtCreator-debug which adds openssh-sshd to it.

Once I removed it. It worked as expected. Sorry for panicking.
I usually get jittery before a release