Getting bad gateway error in "file transfer" feature using Mender server V2.7

mender server: v2.7 production open source
Architecture: Debian X86 Ubuntu18.4
mender convert: v2.4.0
mender-connect: v1.0.0

I have setup self-hosted mender server: v2.7 production grade successfully for “remote terminal” and “file transfer” features experiment. Here remote terminal feature is working fine but getting error “Error uploading file to device bad gateway” as below screenshot. during file upload/download file.

Attached mender-connect.conf file for reference.


Note: I also tried same on latest mender hosted v2.7 as well but getting same error.

can anyone assist me to crack this issue.

We are using hosted mender on a Yocto-created distribution with meta-mender on dunfell-v2021.01 and are facing the same issue.

The web ui shows exactly the same error as @Rohita83 posted above.

# mender-connect --version
mender-connect version 1.0.0    runtime: go1.14.7

Our mender-connect.conf looks like this:

# cat /etc/mender/mender-connect.conf 
{
    "ServerURL": "https://hosted.mender.io",
    "Shell": "/bin/sh",
    "ShellCommand": "/bin/bash",
    "User": "vps"
}

(Note: The Shell key got defaulted to this value by mender-connect.inc. It doesn’t do anything, as the correct key in mender-connect 1.0.0 is ShellCommand. The recipe sets the wrong variable. This is fixed in >= dunfell-v2021.03. This is totally seperate from what’s discussed in this topic.)

@Rohita83: Can you download files from your devices? When I try to download a file, the browser reports a generic “server error”. I also noticed that files which do not have a file extension get an extension .json appended automatically.

@manuel_vps you need to upgrade mender-connect to version 1.1.0 in the device to use file upload/download and port-forwarding.

1 Like

Thank you, @tranchitella!

In case someone’s interested, here’s the changelog for mender-connect 1.1.0.

@manuel_vps Yes, I was getting the same error “server error” in the case of download as per your screenshot.

@Rohita83 are you still experiencing the same error after upgrading mender-connect to version 1.1.0?

@tranchitella I am just creating a new test image with the latest source code mender_convert V2.4.0 which having mender-connect version “latest” (in recently updated code) as below

configs/mender_convert_config:MENDER_ADDON_CONNECT_VERSION="latest"

I have to check it once and then let you know.

Hi Guys,

mender server v2.7 GUI (self-hosted) getting the following errors.

  1. Getting error msg as "“Please check your connection t.sort is not a function” When i click on RELEASES tab as screenshot and unable to upload any artifacts.

  1. Getting error msg as “Couldn’t load deployments. e.sort is not a function Retrying in 23 seconds” When I click on “DEPLOYMENTS” as the screenshot

  1. Getting error “Artifact couldn’t be uploaded. Request failed with status code 413” to upload any artifacts.

can anyone help me to understand the above errors?

@tranchitella

File transfer feature is working fine with latest source code mender_convert V2.4.0 which having mender-connect version “latest” (in recently updated code).

Thanks for the help.

@tranchitella

I am getting an error in the deployment of an artifact in log journalctl -f -u mender-client.service as

image

Could you assist me to track this error.

@Rohita83 can you please check the logs of the deployments service? According to the logs, you are receiving a server error (status code 503).

you means as below

Here all the services are up status.

sudo ./run logs --tail 10 mender-deployments

Getting error as below

@Rohita83 no, I mean something like:

docker logs menderproduction_mender-deployments_1

EDIT: I see you posted the error. The serialization error means the deployments service cannot reach minio. Can you check your minio configuration is correct in the config, and you are pointing to the correct domain name?

@tranchitella
prod.yml file data seems ok i think?

@tranchitella
Output: sudo docker logs --tail 10 menderproduction_mender-deployments_1

I have followed steps from Production installation | Mender documentation

Could you please let me know, how can I resolve this issue?

@tranchitella

Attached prod.yml for reference.
prod.yaml (5.4 KB)

Note: I have replaced ec2-XX-XXX-XXX-XXX with actual DNS.
if anything wrong in the prod.yml file. Please let me know.