Delete a software installed with Mender

While trying to use Mender I used the hello-world Docker example and everything went smooth

Now, the problem is, even if I remove the image and the container, under the device Dashboard in Mender on Installed Software it says that the device has installed docker hello-world-container-update

Is there a chance to remove it?

I’ve tried to remove the device, uninstall and reinstall Mender but it seems it remembers the device in some way

The state files for Mender are in /var/lib/mender/, if you delete them the client should go back to “nothing installed”, and it will be a stranger to the server.

Make sure you delete only the contents, and not the folder itself, which can cause some different types of problems (the folder is often a symlink).

1 Like

On the folder, I have these files

The two folders (modules/scripts) are empty

Yes, delete all of those, including the folders. Just don’t delete the /var/lib/mender folder.

It worked but now under Device type on the Mender Device Dashboard I got an -

trying to launch a Deployment with a device type compatibility = Raspberrypi4 on the device I have deleted the files results in a “Pending” status and doesn’t proceed with the deployment

EDIT It turned out cleaning everything and installing all again fixed the issue