Can't upload artifact from gui 2.3.0

With a production open source 2.3.0 mender-server, I’m unable to upload an artifact through the gui.

When I click on “Create a deployment” it pops up a window that says there are no artifacts, upload one to the repository. I click that and it brings me back to the dashboard.

The only way I can (try to) upload an artifact is on the “Releases” tab.

I’ve tried several file types, plain text files, images, but none have worked.

Using Chrome, the gui shows it’s generating artifact, the upload progress is 100% and seems to complete, but then I see nothing under ‘Release’ - it says there are no artifacts, upload one.

With Firefox, it shows ‘Generating artifact’ but hangs there forever. Beneath that I can see "Upload progress (100%). I opened the javascript console and see this error:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data[artifacts-api.js:38:52](webpack:///src/js/api/artifacts-api.js)

postFormData artifacts-api.js:38

callback client.js:645

g client.js:463

emit index.js:145

onreadystatechange client.js:761

There are some known issues with this and it has been discussed here,

@tranchitella, maybe you have more information?

I too have the same error. I have followed the v2.3 Production server tutorial and cant upload anything. There was no problems with the demo server though.
Interestingly, I can upload it via minio web UI.
I have the same syntax error on the same line, as @cakebread, but before that, I get the following:

POST https://MYDOMAIN/api/management/v1/deployments/artifacts/generate 413 (Request Entity Too Large)

I am using a 6.7MB artifact, the same as mender-demo tutorial. A simple python script does not trigger the 413 error, it uploads to minio but does not show as a new artifact in mender.

Still broken in Version: 2.4.0b1

I believe this is a known problem, some additional details can be found here

Unfortunately this bug was in 2.3 and 2.4.0b1, but is fixed for the 2.4.0 final release.

Here’s one solution related to using self-signed certs.