Can't access to device pages on hosted mender

Hello all,

I cannot access any device detail page on There is an error message.
I tried to flush the cache of my browser (google chrome) and even try to use firefox but the same error appear when I click on any device to display details about it.

This is blocking my workflow. Do you have a solution?

Hi @perceval

I just tried logging in and checking on my account, using Firefox and Chrome.

Which version of chrome are you on?

Also, perhaps @mzedel would be helpful here :slight_smile:


Thanks for the screenshot and I’m sorry to see that! Based on the info there I would assume this is exactly what this PR should address…
Just for context: do you happen to use any of the RBAC functionality?


1 Like

Version 104.0.5112.101 (Official Build) (64-bit) on Ubuntu 22.04

Wow that was fast ^^
Do you know when this PR will be deployed in production, because I still have the problem :s

We do not use any RBAC functionnality

@mzedel @oleorhagen do you have any solution to provide? I cannot access any of my devices details for more than a week now :s

Hi @perceval currently there is a planned update of hosted-mender this week.

As far as I know, this should contain the needed fix.

I am sorry for the issues you are seeing.

In the meantime, could you try a different chrome or firefox version?

I’m on Firefox 103.0.2, and am not seeing these issues.

Hi @oleorhagen ,

Thank you for the update. I’ll keep you posted after the update :slight_smile:

I’m using Firefox 103.0.2 (64-bit) (flatpack edition) too :s
I’ll try different version

Hello @perceval, we rolled out an update to Hosted Mender this morning.
Are you still experiencing this issue?

Hello @tranchitella,

yeah the update is supoer effective, I can access my devices details again on both Chrome and Firefox.
Thank you :slight_smile:

1 Like