Artifact upload error both from web (Network Error) and cli (failed with status 413)

Hi, I am facing issues uploading a system image (with .mender extension) both in the Mender Hosted dashboard (eu region) and through the mender-cli interface.

The file is 4.1GB.

  • If I try to use the Mender Hosted web interface to uplad it as a release, the upload progress resets each time it reaches 5-7% for several times and then it stops trying and states Artifact couldn't be uploaded. Network Error.
  • If I try instead through mender-cli, each time that it reaches exaclty 97% it throws FAILURE: artifact upload to '' failed with status 413.

For the latter case, the error code 413 is, afaik, “content too large”, and indeed the 97% of the file is exactly 4096MB… so I think there is some max size limitation for an artifact, at least if using mender-cli.
For the web intereface issue instead, I tried to upload the file from many networks (both from work, home and in a third place), but the error remains. It is probably on the server side, then.

How this two issues can be solved? I need at least a working procedure to update my devices.

1 Like

I have the exactly same issue. it is currently blocking us from deploying any new releases to our devices that we just moved over to Mender Hosted.

We did not have this limit on the self hosted instance we were running and did not see anything about this in the Mender Hosted documentation.

1 Like

My current workaround is to change the disk compression algorithm to lmza, but I don’t think it will last for long, I still have many data to insert on my devices.

My understanding is the max size is 10G.
I was able to reproduce your issue and created an internal report. We will keep you updated.
Thanks for your report.