Raspberry Pi: Net: No net found


I’m in the process of upgrading from Sumo/Mender 1.6 to Thud/Mender 1.7 for the Raspberry Pi 3 Model B+. My project is almost identical to the standard board integration.

I’ve successfully flashed my new image to a Pi and it works as expected, however when I try to push out the update to a device running Sumo/Mender 1.6, when the device reboots into the update it can’t find the Ethernet adapter.

The very first thing I see on screen when it starts booting is the output:

Net: No ethernet found.
starting USB...
USB0: Core Release: 2.80a

When I run ifconfig, it only shows wlan0 and lo, and eth0 is nowhere to be seen.

Any ideas what this could be? I can provide any extra debug output or config as needed, just let me know where to find it and I’ll upload it.

Thanks in advance!

Check the Known Issues section here Raspberry Pi 3 Model B/B+.

Specifically about “Boot firmware files”, I believe that you are experiencing this.

Hi @mirzak,

Thanks very much for pointing me in the direction of this - I have no idea how I missed this.

I tried doing this workaround but unfortunately I haven’t had much luck. When I added this recipe to my layer, nothing seemed to happen. So I got onto the Pi that I did the update on (from Sumo to Thud), and I manually tried running the following commands (based on the provided recipe)

cp -v /boot/bcm2835-bootfiles/* /uboot
cp -v /boot/*.dtb /uboot
cp -v /boot/*.dtbo /uboot/overlays
cp -v /boot/uImage /uboot

Unfortunately the very first line (bcm2835-bootfiles) didn’t work because that folder doesn’t seem to exist (in fact it doesn’t seem to exist on Sumo either).

I then tried rebooting and UBoot couldn’t boot into the operating system at all.

Does that workaround potentially need to be changed for the Sumo -> Thud upgrade?

Kind Regards,

I realize now that the workaround link only links to 1 of 2 commits.

If you take a look at it like this,

The top two commits are related to this, one installs the bootfiles in to the root filesystem (they are not there by default and that is why you can not find them), and the second commit adds a state-script to that they are copied as part of an Mender update.

Does that workaround potentially need to be changed for the Sumo -> Thud upgrade?

Probably, this is not something that I maintain but I just did that once to demonstrate how one would do that as it seems to keep happening on Raspberry Pi.