# Unable to start on-premise demo server per "Getting Started" instructions

**URL:** <https://hub.mender.io/t/unable-to-start-on-premise-demo-server-per-getting-started-instructions/1414>\
**Category:** General Discussions\
**Created:** [January 8, 2020, 9:31pm UTC](https://hub.mender.io/t/unable-to-start-on-premise-demo-server-per-getting-started-instructions/1414 "2020-01-08T21:31:07Z")\
**Posts on this page:** 1\
**Showing post:** 25

<div class="post-metadata">

**Author:** ![Kris](https://avatars.discourse-cdn.com/v4/letter/k/82dd89/32.png) [@Kris](https://hub.mender.io/u/Kris)\
**Post date:** [February 18, 2020, 8:04pm UTC](https://hub.mender.io/t/unable-to-start-on-premise-demo-server-per-getting-started-instructions/1414/25 "2020-02-18T20:04:23Z")

</div>

@0lmi I am absolutely speechless. I think that is absolutely the problem and thank you so much for your help.

The `docker` command does return 132:

```
karl@mender-test:~/integration-2.2.1$ sudo docker run -it -p 8888:80 openresty/openresty:1.13.6.2-0-alpine
karl@mender-test:~/integration-2.2.1$ echo $?
132

```

And `dmesg` snip shows the same opcode error:

```
[688.851186] traps: openresty[3560] trap invalid opcode ip:7f986ae17448 sp:7ffe09c479b0 error:0 in libluajit-5.1.so.2.1.0[7f986ae0f000+277000]
[689.326609] docker0: port 1(veth7b49596) entered disabled state
[689.328498] vethd100f45: renamed from eth0
[689.397711] docker0: port 1(veth7b49596) entered disabled state
[689.402546] device veth7b49596 left promiscuous mode
[689.402551] docker0: port 1(veth7b49596) entered disabled state

```

Seriously though, great catch, never would have expected that.

---

_[View the full topic](https://hub.mender.io/t/unable-to-start-on-premise-demo-server-per-getting-started-instructions/1414)._
