# Trouble with Mender Server installation

**URL:** <https://hub.mender.io/t/trouble-with-mender-server-installation/7039>\
**Category:** General Discussions\
**Tags:** mender-server, kubernetes, helm\
**Created:** [July 22, 2024, 1:58pm UTC](https://hub.mender.io/t/trouble-with-mender-server-installation/7039 "2024-07-22T13:58:57Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![bztry](https://avatars.discourse-cdn.com/v4/letter/b/6a8cbe/32.png) [@bztry](https://hub.mender.io/u/bztry)\
**Post date:** [July 22, 2024, 1:58pm UTC](https://hub.mender.io/t/trouble-with-mender-server-installation/7039/1 "2024-07-22T13:58:58Z")

</div>

Hello everyone, I wish you a great day,

I’ve been trying to install Mender Server with this tutorial:

[https://docs.mender.io/3.7/server-installation/production-installation-with-kubernetes/mender-server](https://docs.mender.io/3.7/server-installation/production-installation-with-kubernetes/mender-server)

and I’m stuck at this step “Installing the Mender Helm chart”. I created the mender-3.7.5.yml file and try to run it with `helm upgrade --install mender mender/mender -f mender-3.7.5.yml` as per tutorial, but I get the following error message:

```auto
coalesce.go:199: warning: cannot overwrite table with non table for image (map[pullPolicy:IfNotPresent repository:nats tag:2.9.20-alpine])
coalesce.go:199: warning: cannot overwrite table with non table for image (map[pullPolicy:IfNotPresent repository:nats tag:2.9.20-alpine])
coalesce.go:199: warning: cannot overwrite table with non table for image (map[pullPolicy:IfNotPresent repository:nats tag:2.9.20-alpine])
Error: UPGRADE FAILED: template: mender/templates/useradm/deployment.yaml:33:8: executing "mender/templates/useradm/deployment.yaml" at <include "mender.useradmPodTemplate" $context>: error calling include: template: mender/templates/useradm/_podtemplate.yaml:145:31: executing "mender.useradmPodTemplate" at <include "menderVersionMajor" .>: error calling include: template: mender/templates/_helpers.tpl:260:56: executing "menderVersionMajor" at <$mndr_splitted._1>: undefined variable: $mndr_splitted

```

I’m running Ubuntu 20.04, freshly installed and I installed k3s as well as helm per the tutorial all fresh.  
I tried to look up the error messages, but nothing came up, I assume because “mndr\_splitted” is something wrong with the helm config?

Maybe someone of you already encountered this and might be able to help?

Thank you and have a nice day!

---

<div class="post-metadata">

**Author:** ![robgio](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/robgio/32/1760_2.png) [@robgio](https://hub.mender.io/u/robgio)\
**Post date:** [July 22, 2024, 5:06pm UTC](https://hub.mender.io/t/trouble-with-mender-server-installation/7039/2 "2024-07-22T17:06:49Z")

</div>

Hello @bztry ,  
could you please share your values file? Of course without any secret in it 😉

Thanks

---

<div class="post-metadata">

**Author:** ![bztry](https://avatars.discourse-cdn.com/v4/letter/b/6a8cbe/32.png) [@bztry](https://hub.mender.io/u/bztry)\
**Post date:** [July 23, 2024, 5:57am UTC](https://hub.mender.io/t/trouble-with-mender-server-installation/7039/3 "2024-07-23T05:57:15Z")

</div>

Of course, no problem 🙂

I believe it’s just the minimal example from the tutorial:

```auto
global:
  enterprise: false
  image:
    tag: 3.7.5
  mongodb:
    URL: ""
  nats:
    URL: ""
  s3:
    AWS_URI: "https://minio.local"
    AWS_BUCKET: "mender-artifact-storage"
    AWS_ACCESS_KEY_ID: "mkey"
    AWS_SECRET_ACCESS_KEY: "mkey123"
  url: "mendertest.local"

# This enables bitnami/mongodb sub-chart
mongodb:
  enabled: true
  auth:
    enabled: true
    rootPassword: "m123"
    replicaSetKey: "m123"

# This enabled nats sub-chart
nats:
  enabled: true

api_gateway:
  env:
    SSL: false

device_auth:
  certs:
    key: |-
       therewouldbeakeyhere
useradm:
  certs:
    key: |-
       therewouldbeakeyhere

```

Thank you

EDIT: I found the error. I was using the tag `3.7.5` when I should’ve been using `mender-3.7.5`. This was totally my mistake, the docs even recommend the tags and their format.  
I found out when I checked the `_helpers.tpl` file in the helm repo.  
I believe though that this error message is really misleading and maybe there could be more clear error in case of an unexpected tag in the future.

Anyways, cheers and maybe this will help some other people in the future who use a wrong tag 😃

---

<div class="post-metadata">

**Author:** ![robgio](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/robgio/32/1760_2.png) [@robgio](https://hub.mender.io/u/robgio)\
**Post date:** [July 23, 2024, 4:37pm UTC](https://hub.mender.io/t/trouble-with-mender-server-installation/7039/4 "2024-07-23T16:37:45Z")

</div>

Hi @bztry ,  
thanks for your update. Let’s try to address it in this PR: [Fails if tag doesn't start with mender- by oldgiova · Pull Request #324 · mendersoftware/mender-helm · GitHub](https://github.com/mendersoftware/mender-helm/pull/324)
