# Mender-server: fresh production installation continuously restarting

**URL:** <https://hub.mender.io/t/mender-server-fresh-production-installation-continuously-restarting/3270>\
**Category:** General Discussions\
**Tags:** mender-server\
**Created:** [February 25, 2021, 8:16am UTC](https://hub.mender.io/t/mender-server-fresh-production-installation-continuously-restarting/3270 "2021-02-25T08:16:13Z")\
**Posts on this page:** 1\
**Showing post:** 6

<div class="post-metadata">

**Author:** ![joelguittet](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/joelguittet/32/1064_2.png) [@joelguittet](https://hub.mender.io/u/joelguittet)\
**Post date:** [February 26, 2021, 9:06am UTC](https://hub.mender.io/t/mender-server-fresh-production-installation-continuously-restarting/3270/6 "2021-02-26T09:06:46Z")

</div>

I have tried to search by myself in parallel. First to answer your question: it runs a few seconds and stops, nothing on stdout.

I have run:

```auto
docker run -p 8080:80 openresty/openresty:1.13.6.2-0-alpine
echo $?

```

This return error code 132. Googling gave me some results:

- [process exit with code 132 · Issue #39 · openresty/docker-openresty · GitHub](https://github.com/openresty/docker-openresty/issues/39)
- [Exit code 132 · Issue #138 · Kong/docker-kong · GitHub](https://github.com/Kong/docker-kong/issues/138)
- [Unable to start on-premise demo server per "Getting Started" instructions - #19 by Kris](https://hub.mender.io/t/unable-to-start-on-premise-demo-server-per-getting-started-instructions/1414/19) 🙂

Then checking the exact instruction set of my CPU (lscpu =\> Atom D525, Flags: sse3).  
Confirmed googling the characteristics of the CPU, I have not SSE 4.2 which seems to be required to run the openresty container.

Then going to [Docker Hub](https://hub.docker.com/r/openresty/openresty) they indicate nosse42 version is available.

Tried to change openresty to the latest version with no SSE 4.2 which is 1.19.3.1-0-alpine-nosse42 (files docker-compose.storage.minio.yml and extra/failover-testing/docker-compose.failover-server.yml) =\> api-gateway container still continuously restarting with code 132 (the other are fine).

Tried to change openresty to the first version with no SSE 4.2 which is 1.15.8.1-0-alpine-nosse42 (files docker-compose.storage.minio.yml and extra/failover-testing/docker-compose.failover-server.yml) =\> api-gateway container still continuously restarting with code 132 (the other are fine).

So we need a container that will be “1.13.6.2-0-alpine-nosse42” but it’s not provided.

I decided to build this container from sources

```auto
git clone https://github.com/openresty/docker-openresty.git
git checkout 1.13.6.2-0
docker build -t openresty/openresty:1.13.6.2-0-alpine-nosse42 -f alpine/Dockerfile --build-arg "RESTY_LUAJIT_OPTIONS=--with-luajit-xcflags='-DLUAJIT_NUMMODE=2 -DLUAJIT_ENABLE_LUA52COMPAT -mno-sse4.2'" .

```

This took about 40minutes on my machine, it’s very long, but I did it 😃

Then restarted again mender-server with “./run up” and unfortunatly the api-gateway still restarts periodically ☹

Log of the run script (there are plenty of logs from the other containers that seems to be happy):

```auto
mender-api-gateway_1 | setting up automatic reload on host IP address changes for DNS names: mender-useradm mender-inventory mender-deployments mender-device-auth mender-device-adm mender-gui
menderproduction_mender-api-gateway_1 exited with code 132

```

This error is also seen at [Unable to start on-premise demo server per "Getting Started" instructions - #25 by Kris](https://hub.mender.io/t/unable-to-start-on-premise-demo-server-per-getting-started-instructions/1414/25), but there is no conclusion to the post.

Does the api-gateway container requires SSE 4.2 too ?

Joel

---

_[View the full topic](https://hub.mender.io/t/mender-server-fresh-production-installation-continuously-restarting/3270)._
