# Mender-data-grow on dunfell

**URL:** https://hub.mender.io/t/mender-data-grow-on-dunfell/3134
**Category:** General Discussions
**Created:** [January 26, 2021, 10:38am UTC](https://hub.mender.io/t/mender-data-grow-on-dunfell/3134 "2021-01-26T10:38:23Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![MarekBelisko](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/marekbelisko/32/33_2.png) [@MarekBelisko](https://hub.mender.io/u/MarekBelisko)
#### Post date: [January 26, 2021, 10:38am UTC](https://hub.mender.io/t/mender-data-grow-on-dunfell/3134/1 "2021-01-26T10:38:23Z")

</div>

Hi,

I’ve enable `mender-grow-data` feature but it seems it’s not working like should. From log:

```auto
Jan 26 10:30:48 device systemd[1]: Requested transaction contradicts existing jobs: Transaction for data.mount/stop is d
estructive (mender-systemd-growfs-data.service has 'start' job queued, but 'stop' is included in transaction).
Jan 26 10:30:48 device systemd[1]: data.mount: Failed to enqueue stop job, ignoring: Transaction for data.mount/stop is 
destructive (mender-systemd-growfs-data.service has 'start' job queued, but 'stop' is included in transaction).
Jan 26 10:30:49 device systemd[1]: Starting Mender service to grow data partition size...
Jan 26 10:30:49 device systemd[1]: mender-grow-data.service: Main process exited, code=exited, status=1/FAILURE
Jan 26 10:30:49 device systemd[1]: mender-grow-data.service: Failed with result 'exit-code'.
Jan 26 10:30:49 device systemd[1]: Failed to start Mender service to grow data partition size.
Jan 26 10:30:49 device systemd-growfs[246]: Failed to open "/dev/block/179:4": No such file or directory
Jan 26 10:30:49 device systemd[1]: mender-systemd-growfs-data.service: Main process exited, code=exited, status=1/FAILUR
E
Jan 26 10:30:49 device systemd[1]: mender-systemd-growfs-data.service: Failed with result 'exit-code'.

```

Is this know problem or? My target is orangepi-zero. Thanks.

---

<div class="post-metadata">

### Author: ![dellgreen](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/dellgreen/32/85_2.png) [@dellgreen](https://hub.mender.io/u/dellgreen)
#### Post date: [January 26, 2021, 12:21pm UTC](https://hub.mender.io/t/mender-data-grow-on-dunfell/3134/2 "2021-01-26T12:21:12Z")

</div>

does /dev/block/179:4 exist when you login to the device?

---

<div class="post-metadata">

### Author: ![MarekBelisko](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/marekbelisko/32/33_2.png) [@MarekBelisko](https://hub.mender.io/u/MarekBelisko)
#### Post date: [January 26, 2021, 12:22pm UTC](https://hub.mender.io/t/mender-data-grow-on-dunfell/3134/3 "2021-01-26T12:22:56Z")

</div>

Yes. When inspected logs for those grow sevices one was stopped because data was already mounted. It’s weird as dependency is clearly there.

---

<div class="post-metadata">

### Author: ![dellgreen](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/dellgreen/32/85_2.png) [@dellgreen](https://hub.mender.io/u/dellgreen)
#### Post date: [January 26, 2021, 6:46pm UTC](https://hub.mender.io/t/mender-data-grow-on-dunfell/3134/4 "2021-01-26T18:46:13Z")

</div>

hmmm, i guess in your position I would start using some kinda systemd debugging tools to try and find out what is adding `data.mount/stop` to the growfs systemd transaction queue as why would there be a stop transaction request on data partition mounting on boot up? Could it be some option in your /etc/fstab causing an issue, as I believe the data.mount systemd service is auto-generated from fstab?
