# Failed to boot : Must be superuser to use mount

**URL:** https://hub.mender.io/t/failed-to-boot-must-be-superuser-to-use-mount/2343
**Category:** General Discussions
**Tags:** raspberry-pi-4, arm64
**Created:** [August 24, 2020, 12:44am UTC](https://hub.mender.io/t/failed-to-boot-must-be-superuser-to-use-mount/2343 "2020-08-24T00:44:50Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![amnj86](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/amnj86/32/755_2.png) [@amnj86](https://hub.mender.io/u/amnj86)
#### Post date: [August 24, 2020, 12:44am UTC](https://hub.mender.io/t/failed-to-boot-must-be-superuser-to-use-mount/2343/1 "2020-08-24T00:44:50Z")

</div>

Hello all -

I am trying to follow raspberrypi guide to setup mender in my Yocto image. However, after adding the meta-mender layers, including the raspberrypi one, my image stopped booting successfully.

During boot process, I noticed all systemd services that try to mount partitions are failing, including the following:

```auto
[0m] Failed to mount /data.
[FAILED] Failed to mount /var/volatile.
[FAILED] Failed to mount Temporary Directory (/tmp)

```

When I use the emergency shell to check the logs of those systemd services, I am seeing this error:

`"must be superuser to use mount."`

I even tried to manually mount partitions in the emergency shell using the mount command, and I got the same error, when I run `whoami`, I see that I am root user.

Furthermore, when I list the files in the rootfs, everything is owned by uid 1000, including `/sbin/init`, `/bin/mount`, `/lib/systemd/sytemd`… I was under the impression those should be owned by root user.

I would really appreciate any help, I cannot find anything online regarding this issue.

Please note my MACHINE is `raspberrypi4-64`.

Thanks!

---

<div class="post-metadata">

### Author: ![mirzak](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/mirzak/32/2056_2.png) [@mirzak](https://hub.mender.io/u/mirzak)
#### Post date: [August 24, 2020, 6:33am UTC](https://hub.mender.io/t/failed-to-boot-must-be-superuser-to-use-mount/2343/2 "2020-08-24T06:33:13Z")

</div>

Hi @amnj86,

You did not mention which Yocto version you are building.

For reference, you could try [Raspberry Pi 4 Model B - #2](https://hub.mender.io/t/raspberry-pi-4-model-b/889/2).

> Furthermore, when I list the files in the rootfs, everything is owned by uid 1000, including

This is very strange and could explain the problems you are having.

Do you post-process the rootfs image after the Yocto build in any way?

---

<div class="post-metadata">

### Author: ![amnj86](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/amnj86/32/755_2.png) [@amnj86](https://hub.mender.io/u/amnj86)
#### Post date: [August 29, 2020, 4:57pm UTC](https://hub.mender.io/t/failed-to-boot-must-be-superuser-to-use-mount/2343/3 "2020-08-29T16:57:59Z")

</div>

Hi @mirzak  
Thanks for the reply. I wanted to circle back and give update in case it’s useful. The issue was completely solved by building again from a clean state. I’m not sure exactly what was happening, I didn’t have any postinst processes. Anyway, I’m glad I got mender to work ultimately, it was well worth it 🙂

---

<div class="post-metadata">

### Author: ![mirzak](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/mirzak/32/2056_2.png) [@mirzak](https://hub.mender.io/u/mirzak)
#### Post date: [August 31, 2020, 7:19am UTC](https://hub.mender.io/t/failed-to-boot-must-be-superuser-to-use-mount/2343/4 "2020-08-31T07:19:02Z")

</div>

Thanks for reporting back, and glad it worked out for you 😃
