# Error trying to create user with docker demo setup

**URL:** <https://hub.mender.io/t/error-trying-to-create-user-with-docker-demo-setup/8030>\
**Category:** General Discussions\
**Tags:** mender-server\
**Created:** [October 3, 2025, 11:43am UTC](https://hub.mender.io/t/error-trying-to-create-user-with-docker-demo-setup/8030 "2025-10-03T11:43:20Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![joelguittet](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/joelguittet/32/1064_2.png) [@joelguittet](https://hub.mender.io/u/joelguittet)\
**Post date:** [October 3, 2025, 11:43am UTC](https://hub.mender.io/t/error-trying-to-create-user-with-docker-demo-setup/8030/1 "2025-10-03T11:43:20Z")

</div>

Hello there!

Long time I haven’t setup an instance of the mender-server, seems everything has changed in the meantime (previously was working with mender-integration, but now the documentation has changed here).

So I’m trying to create a server for testing purpose and I follow [Evaluation with Docker Compose | Mender documentation](https://docs.mender.io/server-installation/evaluation-with-docker-compose). I’m using v4.0.1 (the latest).

However when creating the user I get an error: “database connection failed: database connection failed: server selection error: context deadline exceeded, …”

I paste below a screenshot of the error too (I’m running on Proxmox machine, there is no copy/paste on the VNC terminal).

 ![image](https://canada1.discourse-cdn.com/flex036/uploads/mender/original/2X/9/9228847acf981b38bc42706c5415b38ca09dcd46.png)

Thanks for any inputs/feedbacks about that!

Joel

---

<div class="post-metadata">

**Author:** ![joelguittet](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/joelguittet/32/1064_2.png) [@joelguittet](https://hub.mender.io/u/joelguittet)\
**Post date:** [October 4, 2025, 3:06pm UTC](https://hub.mender.io/t/error-trying-to-create-user-with-docker-demo-setup/8030/2 "2025-10-04T15:06:30Z")

</div>

Going further with docker ps -a, I see many containers not running and mongo exited 🤯 what is going on ?!

 ![image](https://canada1.discourse-cdn.com/flex036/uploads/mender/original/2X/8/8e8a8742bc29714e45664bece9b6d1d51ef9eb30.png)

Then looked at the mongodb container logs, it complains about the CPU lacking the AVX support: “WARNING: MongoDB 5.0+ requires a CPU with AVX support, and your current system does not appear to have that!”

For more context: the machine is a fresh Debian virtualized in Proxmox. This lack the AVX support by default. See [CPU with AVX support, | Proxmox Support Forum](https://forum.proxmox.com/threads/cpu-with-avx-support.146138/) .

=\> Problem solved after fixing the virtualization config 🙂

Hope this will help people with the same setup!

---

<div class="post-metadata">

**Author:** ![TheYoctoJester](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/theyoctojester/32/1444_2.png) [@TheYoctoJester](https://hub.mender.io/u/TheYoctoJester)\
**Post date:** [October 6, 2025, 9:38am UTC](https://hub.mender.io/t/error-trying-to-create-user-with-docker-demo-setup/8030/3 "2025-10-06T09:38:38Z")

</div>

Hi Joel,

Thanks a lot for sharing!

Greetz,  
Josef
