# Demo server error

**URL:** <https://hub.mender.io/t/demo-server-error/6605>\
**Category:** General Discussions\
**Created:** [March 7, 2024, 8:17am UTC](https://hub.mender.io/t/demo-server-error/6605 "2024-03-07T08:17:52Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![PrimeQH](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/primeqh/32/2120_2.png) [@PrimeQH](https://hub.mender.io/u/PrimeQH)\
**Post date:** [March 7, 2024, 8:17am UTC](https://hub.mender.io/t/demo-server-error/6605/1 "2024-03-07T08:17:52Z")

</div>

root@ubuntu:/home/mender-server/integration-3.7.2# ./demo up  
Starting the Mender demo environment…  
Creating network “integration372\_mender” with the default driver  
Creating integration372\_mender-mongo\_1 …  
Creating integration372\_mender-nats\_1 …  
Creating integration372\_mender-gui\_1 …  
Creating integration372\_mender-nats\_1  
Creating integration372\_minio\_1 …  
Creating integration372\_mender-mongo\_1  
Creating integration372\_minio\_1  
Creating integration372\_mender-mongo\_1 … done  
Creating integration372\_mender-deviceconnect\_1 …  
Creating integration372\_mender-useradm\_1 …  
Creating integration372\_mender-create-artifact-worker\_1 …  
Creating integration372\_mender-iot-manager\_1 …  
Creating integration372\_mender-workflows-worker\_1 …  
Creating integration372\_mender-workflows-server\_1 …  
Creating integration372\_mender-create-artifact-worker\_1  
Creating integration372\_mender-useradm\_1  
Creating integration372\_mender-deviceconnect\_1  
Creating integration372\_mender-workflows-worker\_1  
Creating integration372\_mender-inventory\_1 …  
Creating integration372\_mender-deviceconfig\_1 …  
Creating integration372\_mender-inventory\_1  
Creating integration372\_mender-iot-manager\_1  
Creating integration372\_mender-workflows-server\_1  
Creating integration372\_mender-gui\_1 … done  
Creating integration372\_mender-deployments\_1 …  
Creating integration372\_mender-workflows-server\_1 … done  
Creating integration372\_mender-device-auth\_1 …  
Creating integration372\_mender-device-auth\_1 … done  
Creating integration372\_mender-api-gateway\_1 …  
Creating integration372\_mender-api-gateway\_1 … done  
Waiting for services to become ready…  
Creating a new user…  
time=“2024-03-07T07:31:59Z” level=info msg=“loading plan definitions from configuration” caller=“main.doMain.func1@main.go:145”  
docker exec error: 137

---

<div class="post-metadata">

**Author:** ![PrimeQH](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/primeqh/32/2120_2.png) [@PrimeQH](https://hub.mender.io/u/PrimeQH)\
**Post date:** [March 7, 2024, 8:27am UTC](https://hub.mender.io/t/demo-server-error/6605/2 "2024-03-07T08:27:55Z")

</div>

mender-deployments\_1 | failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mongo-deployments:27017, Type: Unknown, Last error: dial tcp 172.22.0.3:27017: i/o timeout },] }  
mender-create-artifact-worker\_1 | 2024/03/07 08:26:40 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-workflows-worker\_1 | 2024/03/07 08:26:40 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-deviceconnect\_1 | 2024/03/07 08:26:40 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-iot-manager\_1 | time=“2024-03-07T08:26:41Z” level=fatal msg=“failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }”  
mender-workflows-server\_1 | 2024/03/07 08:26:41 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-useradm\_1 | failed to connect to db: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mongo-useradm:27017, Type: Unknown, Last error: dial tcp 172.22.0.3:27017: i/o timeout },] }  
mender-gui\_1 | 127.0.0.1 - - [07/Mar/2024:08:26:42 +0000] “GET /ui/ HTTP/1.1” 200 869 “-” “Wget”  
mender-device-auth\_1 | failed to connect to db: failed to verify mongodb connection: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mongo-device-auth:27017, Type: Unknown },] }  
mender-gui\_1 | 127.0.0.1 - - [07/Mar/2024:08:26:50 +0000] “GET /ui/ HTTP/1.1” 200 869 “-” “Wget”  
integration372\_mender-deployments\_1 exited with code 3

---

<div class="post-metadata">

**Author:** ![PrimeQH](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/primeqh/32/2120_2.png) [@PrimeQH](https://hub.mender.io/u/PrimeQH)\
**Post date:** [March 7, 2024, 8:28am UTC](https://hub.mender.io/t/demo-server-error/6605/3 "2024-03-07T08:28:33Z")

</div>

mender-workflows-worker\_1 | 2024/03/07 08:26:40 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-workflows-worker\_1 | 2024/03/07 08:26:53 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-deviceconnect\_1 | 2024/03/07 08:26:40 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-deviceconnect\_1 | 2024/03/07 08:26:53 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-create-artifact-worker\_1 | 2024/03/07 08:26:40 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-create-artifact-worker\_1 | 2024/03/07 08:26:53 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown, Last error: dial tcp 172.22.0.3:27017: i/o timeout },] }  
mender-useradm\_1 | time=“2024-03-07T08:26:31Z” level=info msg=“loading plan definitions from configuration” caller=“main.doMain.func1@main.go:145”  
mender-useradm\_1 | time=“2024-03-07T08:26:31Z” level=info msg=“User Administration Service starting up” caller=“main.runServer@main.go:178”  
mender-useradm\_1 | failed to connect to db: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mongo-useradm:27017, Type: Unknown, Last error: dial tcp 172.22.0.3:27017: i/o timeout },] }  
mender-useradm\_1 | time=“2024-03-07T08:26:44Z” level=info msg=“loading plan definitions from configuration” caller=“main.doMain.func1@main.go:145”  
mender-useradm\_1 | time=“2024-03-07T08:26:44Z” level=info msg=“User Administration Service starting up” caller=“main.runServer@main.go:178”  
mender-useradm\_1 | failed to connect to db: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mongo-useradm:27017, Type: Unknown },] }  
mender-useradm\_1 | time=“2024-03-07T08:26:56Z” level=info msg=“loading plan definitions from configuration” caller=“main.doMain.func1@main.go:145”  
mender-useradm\_1 | time=“2024-03-07T08:26:56Z” level=info msg=“User Administration Service starting up” caller=“main.runServer@main.go:178”  
mender-workflows-server\_1 | 2024/03/07 08:26:41 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-workflows-server\_1 | 2024/03/07 08:26:54 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-iot-manager\_1 | time=“2024-03-07T08:26:41Z” level=fatal msg=“failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }”  
mender-iot-manager\_1 | time=“2024-03-07T08:26:53Z” level=fatal msg=“failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }”  
mender-device-auth\_1 | failed to connect to db: failed to verify mongodb connection: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mongo-device-auth:27017, Type: Unknown },] }  
mender-device-auth\_1 | failed to connect to db: failed to verify mongodb connection: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mongo-device-auth:27017, Type: Unknown },] }  
mender-gui\_1 | 127.0.0.1 - - [07/Mar/2024:08:26:58 +0000] “GET /ui/ HTTP/1.1” 200 869 “-” “Wget”  
mender-inventory\_1 | time=“2024-03-07T08:27:02Z” level=error msg=“mongo: error pinging mongo ‘server selection error: server selection timeout, current topology: { Type: Unknown, Servers: [{ Addr: mongo-inventory:27017, Type: Unknown, Last error: dial tcp 172.22.0.3:27017: i/o timeout },] }’” caller=“mongo.NewDataStoreMongo.func1@datastore\_mongo.go:147”  
mender-inventory\_1 | failed to connect to db: failed to open mongo-driver session  
mender-deviceconfig\_1 | time=“2024-03-07T08:27:02Z” level=fatal msg=“mongo: error reaching mongo server: server selection error: server selection timeout, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown, Last error: dial tcp 172.22.0.3:27017: i/o timeout },] }” caller=“main.doMain@main.go:108”  
integration372\_mender-deviceconfig\_1 exited with code 0  
mender-deployments\_1 | failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mongo-deployments:27017, Type: Unknown },] }  
mender-workflows-worker\_1 | 2024/03/07 08:27:05 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-deviceconnect\_1 | 2024/03/07 08:27:05 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-create-artifact-worker\_1 | 2024/03/07 08:27:05 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-iot-manager\_1 | time=“2024-03-07T08:27:05Z” level=fatal msg=“failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }”  
mender-gui\_1 | 127.0.0.1 - - [07/Mar/2024:08:27:06 +0000] “GET /ui/ HTTP/1.1” 200 869 “-” “Wget”  
mender-useradm\_1 | failed to connect to db: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mongo-useradm:27017, Type: Unknown },] }  
mender-workflows-server\_1 | 2024/03/07 08:27:06 failed to connect to db: Error reaching mongo server: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mender-mongo:27017, Type: Unknown },] }  
mender-device-auth\_1 | failed to connect to db: failed to verify mongodb connection: server selection error: context deadline exceeded, current topology: { Type: Unknown, Servers: [{ Addr: mongo-device-auth:27017, Type: Unknown },] }

---

<div class="post-metadata">

**Author:** ![TheYoctoJester](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/theyoctojester/32/1444_2.png) [@TheYoctoJester](https://hub.mender.io/u/TheYoctoJester)\
**Post date:** [March 7, 2024, 8:40am UTC](https://hub.mender.io/t/demo-server-error/6605/4 "2024-03-07T08:40:06Z")

</div>

Hi @PrimeQH,

Can you maybe share a little bit more context? Which release of Ubuntu, running on which platform, specifically RAM? Plus, why running under root?

Greetz,  
Josef

---

<div class="post-metadata">

**Author:** ![petermilani80](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/petermilani80/32/1863_2.png) [@petermilani80](https://hub.mender.io/u/petermilani80)\
**Post date:** [November 9, 2024, 3:05am UTC](https://hub.mender.io/t/demo-server-error/6605/5 "2024-11-09T03:05:39Z")

</div>

Hi @TheYoctoJester  
I have the exact same error. Following the directions [Evaluation with Docker Compose | Mender documentation](https://docs.mender.io/3.7/server-installation/evaluation-with-docker-compose) on a Ubuntu 22.04 desktop via ssh (headless). System settings are intel Celeron (2 CPU threads), 16GB RAM.

Exact output

```auto
~/mender_server/integration-3.7.7$ ./demo up
Starting the Mender demo environment...
[+] Running 15/16
 ⠸ Network integration377_mender Created 5.3s 
 ✔ Container integration377-mender-nats-1 Started 1.5s 
 ✔ Container integration377-mender-mongo-1 Started 1.0s 
 ✔ Container integration377-minio-1 Healthy 3.2s 
 ✔ Container integration377-mender-gui-1 Started 1.0s 
 ✔ Container integration377-mender-deviceconfig-1 Started 3.0s 
 ✔ Container integration377-mender-workflows-server-1 Started 3.3s 
 ✔ Container integration377-mender-iot-manager-1 Started 2.9s 
 ✔ Container integration377-mender-inventory-1 Started 2.6s 
 ✔ Container integration377-mender-deployments-1 Started 4.1s 
 ✔ Container integration377-mender-useradm-1 Started 2.6s 
 ✔ Container integration377-mender-workflows-worker-1 Started 3.7s 
 ✔ Container integration377-mender-deviceconnect-1 Started 3.7s 
 ✔ Container integration377-mender-create-artifact-worker-1 Started 3.4s 
 ✔ Container integration377-mender-device-auth-1 Started 4.3s 
 ✔ Container integration377-mender-api-gateway-1 Started 5.0s 
Waiting for services to become ready...
Creating a new user...
time="2024-11-09T03:02:22Z" level=info msg="loading plan definitions from configuration" caller="main.doMain.func1@main.go:145"
docker exec error: 137

```

---

<div class="post-metadata">

**Author:** ![petermilani80](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/petermilani80/32/1863_2.png) [@petermilani80](https://hub.mender.io/u/petermilani80)\
**Post date:** [November 9, 2024, 3:57am UTC](https://hub.mender.io/t/demo-server-error/6605/6 "2024-11-09T03:57:39Z")

</div>

There are a couple of examples of the demo failing due to cpu architecture support such as sse4\_2 [Unable to start on-premise demo server per "Getting Started" instructions - #23 by 0lmi](https://hub.mender.io/t/unable-to-start-on-premise-demo-server-per-getting-started-instructions/1414/23)

This exact issue doesn’t seem to be the case as output of `cat /proc/info` seems to show support for sse4\_2 in flags:

```auto
cat /proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model : 156
model name	: Intel(R) Celeron(R) N4505 @ 2.00GHz
stepping	: 0
microcode	: 0x24000026
cpu MHz : 800.082
cache size	: 4096 KB
physical id	: 0
siblings	: 2
core id : 0
cpu cores	: 2
apicid : 0
initial apicid	: 0
fpu : yes
fpu_exception	: yes
cpuid level	: 27
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg cx16 xtpr pdcm sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave rdrand lahf_lm 3dnowprefetch cpuid_fault epb cat_l2 cdp_l2 ssbd ibrs ibpb stibp ibrs_enhanced tpr_shadow flexpriority ept vpid ept_ad fsgsbase tsc_adjust smep erms rdt_a rdseed smap clflushopt clwb intel_pt sha_ni xsaveopt xsavec xgetbv1 xsaves split_lock_detect dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp hwp_pkg_req vnmi umip waitpkg gfni rdpid movdiri movdir64b md_clear flush_l1d arch_capabilities
vmx flags	: vnmi preemption_timer posted_intr invvpid ept_x_only ept_ad flexpriority apicv tsc_offset vtpr mtf vapic ept vpid unrestricted_guest vapic_reg vid ple shadow_vmcs ept_mode_based_exec tsc_scaling usr_wait_pause
bugs : apic_c1e spectre_v1 spectre_v2 spec_store_bypass swapgs srbds mmio_stale_data bhi
bogomips	: 3993.60
clflush size	: 64
cache_alignment	: 64
address sizes	: 39 bits physical, 48 bits virtual
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model : 156
model name	: Intel(R) Celeron(R) N4505 @ 2.00GHz
stepping	: 0
microcode	: 0x24000026
cpu MHz : 789.349
cache size	: 4096 KB
physical id	: 0
siblings	: 2
core id : 1
cpu cores	: 2
apicid : 2
initial apicid	: 2
fpu : yes
fpu_exception	: yes
cpuid level	: 27
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg cx16 xtpr pdcm sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave rdrand lahf_lm 3dnowprefetch cpuid_fault epb cat_l2 cdp_l2 ssbd ibrs ibpb stibp ibrs_enhanced tpr_shadow flexpriority ept vpid ept_ad fsgsbase tsc_adjust smep erms rdt_a rdseed smap clflushopt clwb intel_pt sha_ni xsaveopt xsavec xgetbv1 xsaves split_lock_detect dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp hwp_pkg_req vnmi umip waitpkg gfni rdpid movdiri movdir64b md_clear flush_l1d arch_capabilities
vmx flags	: vnmi preemption_timer posted_intr invvpid ept_x_only ept_ad flexpriority apicv tsc_offset vtpr mtf vapic ept vpid unrestricted_guest vapic_reg vid ple shadow_vmcs ept_mode_based_exec tsc_scaling usr_wait_pause
bugs : apic_c1e spectre_v1 spectre_v2 spec_store_bypass swapgs srbds mmio_stale_data bhi
bogomips	: 3993.60
clflush size	: 64
cache_alignment	: 64
address sizes	: 39 bits physical, 48 bits virtual
power management:

```

However following the instructions on a different machine corei9, the getting demo server works as per the documentation and generates a user.

---

<div class="post-metadata">

**Author:** ![alfrunes](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/alfrunes/32/703_2.png) [@alfrunes](https://hub.mender.io/u/alfrunes)\
**Post date:** [November 11, 2024, 9:39am UTC](https://hub.mender.io/t/demo-server-error/6605/7 "2024-11-11T09:39:51Z")

</div>

Hello @petermilani80 👋

I believe MongoDB might be the issue; starting from version 5.0, MongoDB [requires the AVX instruction set](https://www.mongodb.com/docs/manual/administration/production-notes/#platform-support-notes) for x86\_64. Although I would not recommend running software out of a support, the only workaround I think could make it work would be downgrading MongoDB (`services.mender-mongo.image` in `docker-compose.yml`) to 4.4. Please keep in mind that this version has been out of support since February this year and won’t receive any further updates.
