# Couldn't load deployments. Error: Unsuccessful HTTP Response Retrying in

**URL:** <https://hub.mender.io/t/couldnt-load-deployments-error-unsuccessful-http-response-retrying-in/4509>\
**Category:** General Discussions\
**Created:** [January 19, 2022, 11:39pm UTC](https://hub.mender.io/t/couldnt-load-deployments-error-unsuccessful-http-response-retrying-in/4509 "2022-01-19T23:39:08Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Stella](https://avatars.discourse-cdn.com/v4/letter/s/5fc32e/32.png) [@Stella](https://hub.mender.io/u/Stella)\
**Post date:** [January 19, 2022, 11:39pm UTC](https://hub.mender.io/t/couldnt-load-deployments-error-unsuccessful-http-response-retrying-in/4509/1 "2022-01-19T23:39:08Z")

</div>

Hi! Has anyone seen this error at the bottom of their mender site before?  
“Couldn’t load deployments. Error: Unsuccessful HTTP Response Retrying in 27 seconds…”

I suspect it might have something to do with certificates but I’m unsure.

Information from the Mender docs.

### Mender Server

You can either generate new certificates by following the tutorial for [generating certificates](https://docs.mender.io/development/server-installation/installation-with-docker-compose#certificates-and-keys), or obtain the certificates in a different way - for example from your existing Certificate Authority. In either case the certificates on the client and server must be the same.

If CA is the issue, where would I find my client and server CAs?

Any help is appreciated, thank you!

---

<div class="post-metadata">

**Author:** ![mzedel](https://yyz2.discourse-cdn.com/flex036/user_avatar/hub.mender.io/mzedel/32/261_2.png) [@mzedel](https://hub.mender.io/u/mzedel)\
**Post date:** [January 20, 2022, 6:37pm UTC](https://hub.mender.io/t/couldnt-load-deployments-error-unsuccessful-http-response-retrying-in/4509/2 "2022-01-20T18:37:21Z")

</div>

Heyho @Stella,  
there are a few possibilities for this to happen, so I think we need some more information about your setup (e.g. is this a docker-compose or helm based setup, where does your storage live (minio or S3)). If you’re just starting out the certificates included in the demo setup should still be fine, if things ran for a while, the issue might be very different…  
One issue I’ve come across locally that causes the same message is due to `minio` not starting up due to a lack of storage, which in turn prevents the `deployments` service from starting. This is of course only relevant if you don’t use Mender with e.g. a S3 configuration. Take the following with extra care, but my goto solution is to run `docker system prune -a` - this however might well remove more than you want to.  
Unfortunately that’s all I can recommend for now, but I’ll be happy to help with a bit more information about your setup.

---

<div class="post-metadata">

**Author:** ![Stella](https://avatars.discourse-cdn.com/v4/letter/s/5fc32e/32.png) [@Stella](https://hub.mender.io/u/Stella)\
**Post date:** [January 20, 2022, 7:04pm UTC](https://hub.mender.io/t/couldnt-load-deployments-error-unsuccessful-http-response-retrying-in/4509/3 "2022-01-20T19:04:26Z")

</div>

Hi,

It is a docker-compose and this is an old project. I’m unsure what you mean by where my storage lives but I have a MQTT broker hosted on aws EC2. I recently had someone update the certificates on our MQTT broker so I’m wondering if that affected anything on the Mender server as from what I’m reading certificates must be the same on the client and server.

What I believe is happening is that in our production.yml file  
DEPLOYMENTS\_AWS\_URI: “[https://DOMAINNAME.COM](https://DOMAINNAME.COM)”

The variable has the https but currently our [DOMAINNAME.com](http://DOMAINNAME.com) has expired certificates. So I’m wondering if updating the certificates on the mender server will resolve this issue.
